Degraded Application Performance

Incident Report for TablesReady

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 12:58 EST

Monitoring

A fix has been implemented and service has been restored to normal levels. We are continuing to monitor performance.
Posted Feb 18, 2026 - 11:47 EST

Update

The fix was partially successful and the app is much more usable, but we will implement a further fix to bring everything back to normal. You may again experience a brief period where the app is not accessible.
Posted Feb 18, 2026 - 11:13 EST

Identified

The issue has been identified and a fix is being deployed. You may see a brief period where the app is not accessible.
Posted Feb 18, 2026 - 10:40 EST

Investigating

We are investigating the cause of slow database queries retrieving current parties data.
Posted Feb 18, 2026 - 10:26 EST
This incident affected: TablesReady Services (TablesReady Web App).